ACAPI_​Element_​GetElementsWithClassification

Query elements with the given classification.

    GSErrCode  ACAPI_Element_GetElementsWithClassification (
        const API_Guid&          classificationItemGuid,
        GS::Array<API_Guid>&     elemGuids
    );

 

Parameters

classificationItemGuid
[in] The identifier of the classification item.
elemGuids
[out] The identifiers of the elements with the given classification.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The classificationItemGuid did not refer to a valid classification item.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions