ACAPI_​Property_​DeletePropertyGroup

Deletes a property group and all of the property definitions inside in the current plan.

    GSErrCode  ACAPI_Property_DeletePropertyGroup (
        const API_Guid&      groupGuid
    );
    

 

Parameters

groupGuid
[in] The identifier of the property group to delete.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The groupGuid parameter did not refer to a valid property group.
APIERR_NOACCESSRIGHT
Do not have the right to delete a property group on a teamwork server.

For other common API errors see the API Errors document.

 

Example



GSErrCode DeleteAllPropertyGroups ()
{
    GS::Array<API_PropertyGroup> groups;
    GSErrCode error = ACAPI_Property_GetPropertyGroups (groups);
    for (UInt32 i = 0; error == NoError && i < groups.GetSize (); i++) {
        error = ACAPI_Property_DeletePropertyGroup (groups[i].guid);
    }

    return error; 
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions