ACAPI_​Database_​GetLast3DDefLevels

Retrieves the 3D default levels for the construction elems.

    GSErrCode ACAPI_Database_GetLast3DDefLevels (
        const GS::Array<API_ElemType>&     elemTypes,
        GS::Array<double>&                 levels
    );

 

Parameters

elemTypes
[in] The elem types for which you want to obtain the 3D default levels.
levels
[out] The 3D default levels for the elem types given in the elemIDs array.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Retrieves the 3D default levels for the types passed in the elemIDs array. Possible elem types: Wall, Column, Beam, Symbol, Light, Slab, Roof, Mesh.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API Functions