APIDo_​CloseID

Closes the current project window.

    GSErrCode ACAPI_Automate (
        APIDo_CloseID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_REFUSEDCMD
The command is not allowed to call.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to perform a Close command in the server application.

It cannot be called from notification level; the command is refused if other addons are running. Calling this function may notify other addons on the event. The caller addon does not get any notification. See the Notification Manager for further details.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

Not for public usage.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

ACAPI_Automate, API Functions