API_​AnalyticalEdgeLoadType

Describes a Structural Analytical Model Member Edge Load.

    typedef struct {
        API_AnalyticalEdgeLoad_Settings    edgeLoadSettings;
        API_AnalyticalMemberPartRef        loadedMemberPartRef;
    } API_AnalyticalEdgeLoadType;

 

Members

edgeLoadSettings 
The Analytical Edge Load settings.
loadedMemberPartRef 
The Analytical Member part reference where the Analytical Edge Load is applied.

 

Remarks

An Edge Load element can be created with the aid of ACAPI_Element_Create and it can be removed via the ACAPI_Element_Delete function. Currently the ACAPI_Element_Change function is unavailable for Analytical Edge Loads.

Requirements

Version: API 25 or later
Header: APIdefs_AnalyticalElements.h

 

See Also

API Types

API Element

ACAPI_Element_Get

ACAPI_Element_Create

ACAPI_Element_Delete