ACAPI_​AttributeList_​DeleteProperty

Makes a property definition unavailable for all of given attributes.

    GSErrCode  ACAPI_AttributeList_DeleteProperty (
        const API_Guid&                     definitionGuid,
        const GS::Array<API_Attr_Head>&     attrHeaders
    );

 

Parameters

definitionGuid
[in] The GUID of the definition to remove from the attributes.
attrHeaders
[in] The array of attributes, that the property should be available for.

 

Return Values

NoError
The function has completed with success.
APIERR_NOACCESSRIGHT
Do not have the right to modify a property definition on a teamwork server.
APIERR_BADID
Inexistent property item.
APIERR_READONLY
Tried to modify a read-only property (for example a property coming from a hotlink).

For other common API errors see the API Errors document.

 

Example



GSErrCode DeleteIntegerPropetiesOfSelection (GS::Array<API_Attr_Head>& attributes)
{
    GS::Array<API_PropertyDefinition> definitions;
    ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions);

    for (UIndex i = 0; i < definitions.GetSize (); ++i) {
        if (definitions[i].collectionType == API_PropertySingleCollectionType &&
            definitions[i].valueType == API_PropertyIntegerValueType) {
            GSErrCode err = ACAPI_AttributeList_DeleteProperty (definitions[i].guid, attributes));
            if (err != NoError) {
                return err;
            }
        }
    }
    return NoError;
}

        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions