APIAny_​InitMDCLParameterListID

Initializes a parameter list to pass to an other add-on.

    GSErrCode ACAPI_Goodies (
        APIAny_InitMDCLParameterListID,
        GSHandle*     params
    );

 

Parameters

params
[out] The address of a handle to be initialized

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params is nullptr
APIERR_MEMFULL
low memory condition

For other common API errors see the API Errors document.

 

Remarks

This function is used to initialize a parameter list handle used in inter-addon communications.
For the utilization details of APIAny_InitMDCLParameterListID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Manager example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
APIAny_AddMDCLParameterID
APIAny_ChangeMDCLParameterID
APIAny_FreeMDCLParameterListID
APIAny_GetMDCLParameterID
APIAny_GetMDCLParameterNumID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions