APIEnv_​IsInCurtainWallEditModeID

Returns if applicaton is in curtain wall editing mode.

    GSErrCode ACAPI_Environment (
        APIEnv_IsInCurtainWallEditModeID,
        bool*         isInEditMode,
        API_Guid*     editedCurtainWall
    );

 

Parameters

isInEditMode
[out] Is the application in curtain wall editing mode?
editedCurtainWall
[out] (optional) The GUID of the currently edited curtain wall.

 

Return Values

NoError
The function completed with success.
APIERR_BADPARS
isInEditMode is nullptr

For other common API errors see the API Errors document.

 

Remarks

You can use this function to check the state of the applicaton; many things work differently in curtain wall editing mode.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment, API Functions