ACAPI_​Element_​GetPropertyValuesByGuid

Retrieves the specified property definitions (defined by their GUIDs) with values.

    GSErrCode  ACAPI_Element_GetPropertyValuesByGuid (
        const API_Guid&                              elemGuid,
        const GS::Array<API_Guid>&     propertyDefinitions,
        GS::Array<API_Property>&                     properties
    );

 

Parameters

elemGuid
[in] The element GUID to search for.
propertyDefinitions
[in] The property definition GUIDs to get the values for.
properties
[out] The definitions and values of the requested properties.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element.

For other common API errors see the API Errors document.

 

Example


GSErrCode GetAllPropertyValues (const API_Guid& elemGuid, GS::Array<API_PropertyValue>& values)
{
    GS::Array<API_PropertyDefinition> definitions;
    GSErrCode error = ACAPI_Element_GetPropertyDefinitions (elemGuid, API_PropertyDefinitionFilter_UserDefined, definitions);
    if (error == NoError) {
        GS::Array<API_Guid> propertyDefinitionList;
        for (UInt32 i = 0; i ACAPI_Element_GetPropertyValuesByGuid (elemGuid, propertyDefinitionList, properties);
        if (error == NoError) {
            for (UInt32 i = 0; i < properties.GetSize (); i++) {
                if (properties[i].isDefault) {
                    values.Push (properties[i].definition.defaultValue);
                } else {
                    values.Push (properties[i].value);
                }
            }
        }
    }

    return error;
}
        
For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions