API_​NavigatorView

Representation of a Navigator view item.

    typedef struct {
        API_Box                  zoom;
        char                     modelViewOptName[API_LongNameLen];
        API_ModelViewOptions     *modelViewOpt;
        API_StructureDisplay     structureDisplay;
        char                     layerCombination[API_AttrNameLen];
        API_LayerStat            **layerStats;
        Int32                    drawingScale;
        char                     dimName[API_LongNameLen];
        API_DimensionPrefs       *dimPrefs;
        bool                     saveZoom;
        bool                     saveDispOpt;
        bool                     saveLaySet;
        bool                     saveDScale;
        bool                     saveDim;
        bool                     savePenSet;
        bool                     saveStructureDisplay;
        bool                     filler_2[5];
        char                     penSetName[API_AttrNameLen];
        API_PenType              *pens;
        bool                     ignoreSavedZoom;
        bool                     filler_3[7];
        API_Tranmat              tr;
        API_Guid                 renovationFilterGuid;
        GS::uchar_t              overrideCombination[API_UniLongNameLen];
        GS::uchar_t              d3styleName[API_UniLongNameLen];
        GS::uchar_t              renderingSceneName[API_UniLongNameLen];
        bool                     usePhotoRendering;
    } API_NavigatorView;

 

Members

zoom
The associated zoom box defined in model coordinates. Valid only if the saveZoom field is true.
modelViewOptName Changed in API 11
Name of the view’s Model View option [display option in old terminology]. Valid only if the saveDispOpt field is true.
modelViewOpt 10
Model View option stored for this view, if custom. Valid only if the saveDispOpt field is true. Do not forget to free this pointer if not needed any more.
structureDisplay 12
The Partial Structure Display state of the view. See API_StructureDisplay.
layerCombination API 11
Layer combination name of the view. Valid only if the saveLaySet field is true.
The length of this field has been raised up to 256 characters.
layerStats
Handle to a set of layer status stored for the view. Valid only if the saveLaySet field is true and layerCombination is empty, otherwise it should be set to nullptr.
Do not forget to dispose this handle if not needed any more.
drawingScale
The drawing scale associated with the view. Valid only if the saveDScale field is true.
dimName 10
Dimension style attribute name. Valid only if the saveDim field is true.
dimPrefs 10
Dimensioning settings stored for this view (only if custom). Valid only if the saveDim field is true. Do not forget to free this pointer if not needed any more.
saveZoom
Zoom box is stored in the view. If false, the zoom field does not contain valid data.
saveDispOpt
Display options are stored in the view. If false, the displayOpt field does not contain valid data.
saveLaySet
Layer settings are stored in the view. If false, the layerCombination and the layerStats fields do not contain valid data.
saveDScale
Drawing scale is stored in the view. If false, the drawingScale field does not contain valid data.
saveDim 10
Dimensioning is stored in this view. If false, the dimName and the dimPrefs fields do not contain valid data.
savePenSet 11
Store the penset.
saveStructureDisplay 12
Partial Structure Display setting is stored in the view.
penSetName[API_AttrNameLen] 11
Penset name (empty if custom).
pens 11
Pens of the pen table (only if custom).
ignoreSavedZoom 12
If this value is true, the saved zoomBox for the view is not used when changing between views. (in View Organizer this can be set with the “Do not apply saved zooms when changing views” check)
renovationFilterGuid 15
Renovation filter used by this navigator view.
overrideCombination 20
The currently active override combination in this navigator view (or empty string if there is no active override combination).
d3styleName 21
3D style name (or empty string if this is not a 3D view).
renderingSceneName 21
Rendering scene name (or empty string if this is not a rendered view).
usePhotoRendering 21
Use photorendering in visualization (for rendered views).

 

Remarks

You can retrieve information about a view via APINavigator_GetNavigatorViewID and you are able to change it with APINavigator_ChangeNavigatorViewID function.

 

Requirements

Version: API 4.3 or later
Header: APIdefs_Navigator.h

 

See Also

API_NavigatorItem
API_NavigatorSet
API Types