ACAPI_​ElementGroup_​GetAllGroupedElems

Returns all elements of the given group.

    GSErrCode  ACAPI_ElementGroup_GetAllGroupedElems (
        const API_Guid&         groupGuid
        GS::Array<API_Guid>*    elemGuids
    );

 

Parameters

groupGuid 
[in] Unique ID of the passed group.
elemGuids 
[out] Array of all element unique IDs which below the passed group.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
Passed group ID is invalid.
APIERR_BADPARS
Invalid value passed in the parameters.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get all elements of a given group. The retrieved array contains all elements which are below the group subtree (root of subtree identified the passed groupGuid).

 

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetGroup
ACAPI_ElementGroup_GetRootGroup
ACAPI_ElementGroup_GetGroupedElems
API Functions