APIEnv_​GetMagicWandSetsID

Returns information on curve tracing parameters.

    GSErrCode ACAPI_Environment (
        APIEnv_GetMagicWandSetsID,
        API_MagicWandInfo*     magicWandInfo
    );

 

Parameters

magicWandInfo
[out] Parameters of the ‘Magic Wand Settings…’ dialog.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
magicWandInfo is nullptr.
APIERR_NOPLAN
No open project.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the parameters can be set in the ‘Magic Wand Settings…’ dialog.

Refer to the API_MagicWandInfo structure to get further details.

 

Example


API_MagicWandInfo  magicInfo;
GSErrCode          err;

BNZeroMemory (&magicInfo, sizeof (API_MagicWandInfo));
err = ACAPI_Environment (GetMagicWandSetsID, &magicInfo, nullptr);

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_MagicWandInfo,
ACAPI_Environment, API Functions