APIAny_​NeigToCoordID

Returns the coordinate of a neig.

    GSErrCode ACAPI_Goodies (
        APIAny_NeigToCoordID,
        API_Neig*        neig,
        API_Coord3D*     coord3D,
        API_Coord3D*     coord3DDocument
    );

 

Parameters

neig
[in] neig data
coord3D
[out] coordinate assigned to the passed neig
coord3DDocument API 13 feature
[out] coordinate over a 3D Document window

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
any of the parameters are nullptr
APIERR_BADID
Invalid neigID has been passed

For other common API errors see the API Errors document.

 

Remarks

This function is used to convert neig to coordinate.

Refer to the API_NeigID structure to get information how neigs are assigned to the element geometry.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_Neig, API_Coord3D,
ACAPI_Goodies, API Functions