ACAPI_​AnalyticalModel_​GetAnalyticalSurfaceLoadGeometry

Returns the Structural Analytical Surface Load Geometry.

    GSErrCode  ACAPI_AnalyticalModel_GetAnalyticalSurfaceLoadGeometry (
        const API_Guid&                amGuid,
        const API_Guid&                elemGuid,
        API_SurfaceLoadCustomData&     api_analyticalSurfaceLoadGeometry
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Surface Element.
api_analyticalSurfaceLoadGeometry
[out] The Structural Analytical Surface Load geometry.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 25 or later
Header: ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions

API_SurfaceLoadCustomData