ACAPI_​Element_​AddClassificationItem

Classifies an element.

    GSErrCode  ACAPI_Element_AddClassificationItem (
        const API_Guid&             elemGuid,
        const API_Guid&             itemGuid
    );

 

Parameters

elemGuid
[in] The identifier of the element which should receive the new classification.
itemGuid
[in] The guid of the classification item, that should be added to the element.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The elemGuid did not refer to a valid element or itemGuid did not refer to a valid classification item.
APIERR_READONLY
The element can not be modified (i.e. from a hotlink) or you do not have the right to classify elements in the current teamwork plan.
APIERR_BADCLASSIFICATION
The classification item is not available for the given element.

For other common API errors see the API Errors document.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions