APIDb_​ResetCurrentDatabaseID

Deletes the database elements of the current window and sets up a new, empty environment.

    GSErrCode ACAPI_Database (
        APIDb_ResetCurrentDatabaseID
    );

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE
The current database is not a custom drawing or owned by an other addon,

For other common API errors see the API Errors document.

 

Remarks

This function is used to delete all elements from the current database. It returns an error if the active database is not a custom window owned by the caller addon.

To reset the content of the current (front) window use the APIDb_ResetCurrentWindow function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

APIDb_ResetCurrentWindow,
ACAPI_Database, API Functions