ACAPI_​Override_​DeleteOverrideCombination

Deletes an override combination identified by its guid.

        GSErrCode  ACAPI_Override_DeleteOverrideCombination (
            const API_Guid&       combination
        );
    

 

Parameters

combination
[in] The guid of the combination to delete.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid did not refer to a valid override combination.
APIERR_NOACCESSRIGHT
Tried to delete a built-in combination.

For other common API errors see the API Errors document.

 

Example



GSErrCode DeleteAllUserDefinedOverrideCombination ()
{
    GS::Array<API_Guid> combinationList;
    GSErrCode err = ACAPI_Override_GetOverrideCombinationList (combinationList);
    if (err == NoError) {
        for (USize i = 0; i < combinationList.GetSize(); ++i) {
            ACAPI_Override_DeleteOverrideCombination (combinationList[i]);
        }
    }
    
    return err;
}

        
For more detailed examples, please see the Override_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Visual Override,
API Functions