APIDb_​GetDocumentFrom3DDatabasesID

Returns the list of unique IDs of all document 3D databases.

    GSErrCode ACAPI_Database (
        APIDb_GetDocumentFrom3DDatabasesID,
        API_DatabaseUnId**            databaseUnIds,
        GS::Array<API_DatabaseUnId>*  databaseUnIdArray
    );

 

Parameters

databaseUnIds
[out] The list of document 3D database unique IDs. Note this is not handle; it’s the address of a pointer. See the example below.
databaseUnIdArray API 22
[out] the array of 3D document databases, in a more recent form. Pass the address of an appropriate GS::Array<> to get the result. This parameter has precedence over the other databaseUnIds parameter.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
dbUnIDs is nullptr
APIERR_NOPLAN
the plan database does not exist

For other common API errors see the API Errors document.

 

Remarks

This function is used to return the database unique IDs of all document 3D databases. Currently this is the only way you can access these kind of databases because they don’t have markers.

You can switch to any of the other databases by calling the APIDb_ChangeCurrentDatabase function.

 

Example

The Attribute Manager add-on uses this function to collect all the used attributes from the document 3D databases.


GS::Array<API_DatabaseUnId> document3Ds;

GSErrCode err = ACAPI_Database (APIDb_GetDocumentFrom3DDatabasesID, nullptr, &document3Ds);
if (err == NoError) {
    // process the information
}

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Database.h

 

See Also

API_DatabaseUnId
APIDb_GetDetailDatabasesID, APIDb_GetLayoutDatabasesID, APIDb_GetMasterLayoutDatabasesID, APIDb_ChangeCurrentDatabase
ACAPI_Database, API Functions