Returns the mapping table of the proxy elements and the source elements of the given hotlink instance.
GSErrCode ACAPI_Database ( APIDb_GetHotlinkProxyElementTableID, const API_Guid* hotlinkGuid, GS::HashTable<API_Guid, API_Guid>* proxyElementTable );
Parameters
- hotlinkGuid
- [in] The guid of the hotlink instance.
- proxyElementTable
- [out] A hashtable in which the keys are the proxy elements in the current project and the values are the source elements from the hotlinked project.
Return Values
NoError
- The function has completed with success.
APIERR_NOPLAN
- There is no opened project.
APIERR_BADID
- The
hotlinkGuid
is invalid, it does not refer to an element. APIERR_BADELEMENTTYPE
- The
hotlinkGuid
does not belong to a hotlink instance.
For other common API errors see the API Errors document.
Requirements
- Version: API 25 or later
- Header: APIdefs_Database.h
See Also
API_HotlinkType
APIDb_GetHotlinkNodeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkNodeTreeID
ACAPI_Database
API Functions