ACAPI_​Element_​GetClassificationInSystemDefault

Retrieves a classification of a default elem in a given classification system.

    GSErrCode  ACAPI_Element_GetClassificationInSystemDefault (
        const API_ElemType&         type,
        const API_Guid&             systemGuid,
        API_ClassificationItem&     item
    );

 

Parameters

type
[in] Type of the default element.
systemGuid
[in] The guid of the classification system in which the classification item should be retrieved.
item
[out] The retrieved classification item (empty with null guid if the elem doesn’t have a classification in the given system).

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The type did not refer to a valid default element or systemGuid did not refer to a valid classification system.

For other common API errors see the API Errors document.

 

Remarks

New in API 26 From version 26 the typeID and variationID parameters were merged into a single API_ElemType parameter.

 

Example

For detailed examples, please see the Classification_Test add-on.

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification,
API Functions