APIAny_​GetBuiltInLibpartUnIdID

Retrieves the GUID of a built-in library part.

    GSErrCode ACAPI_Goodies (
        APIAny_GetBuiltInLibpartUnIdID,
        short     templateFileResID,
        char*     lpfUnId
    );

 

Parameters

templateFileResID
[in] the library part template ‘FILE’ resource ID
lpfUnId
[out] the required unique ID in string format

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
lpfUnId is nullptr or templateFileResID contains invalid data.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the GUID of a library part compiled into the add-on’s module as ‘FILE’ resource.
For more information about built-in library parts see ACAPI_Register_BuiltInLibrary.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_LibPart, ACAPI_Goodies,
ACAPI_Register_BuiltInLibrary, API Functions