APIDb_​GetZoomID

Returns the actual zoom parameters of the current database.

    GSErrCode ACAPI_Database (
        APIDb_GetZoomID,
        API_Box*     zoomBox,
        API_Tranmat* tranmat
    );

 

Parameters

zoomBox
[out] The actual zoom parameters
tranmat Featuring API 18
[out] Contains the floor plan grid rotation.

 

Return Values

NoError
The function has completed with success
APIERR_BADDATABASE
The current database is not 2D drawing type
APIERR_BADPARS
zoomBox is nullptr

For other common API errors see the API Errors.

 

Remarks

This function is used to retrieve the zoom box of the window of the current database if it is 2D drawing type window.

To change the actual zoom box refer to the APIDb_SetZoomID function.

To restore one of the previous zooms use the APIDb_ReSetZoomID function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Database.h

 

See Also

API_Box, API_Tranmat
APIDb_SetZoomID, APIDb_ReSetZoomID,
ACAPI_Database, API Functions