API_​PrimLine

A primitive line.

    typedef struct {
        API_Prim_Head      head;
        API_AttributeIndex ltypeInd;
        short              determination;
        short              filler_1;
        double             penWeight;
        API_Coord          c1;
        API_Coord          c2;
    } API_PrimLine;

 

Members

head
General primitive element header.
ltypeInd
Line type attribute index.
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

penWeight
Thickness of the line; overrides the pen attribute’s penWeight in the header in [mm].
c1
One endpoint of the line.
c2
The other endpoint of the line.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_PrimElement, API_Prim_Head, API_Coord, API Types