APIEnv_​DeleteGhostRecordID

Deletes a Virtual Trace (ghost) record.

    GSErrCode ACAPI_Environment (
        APIEnv_DeleteGhostRecordID,
        const API_GhostRecord*     ghostRecord
    );

 

Parameters

ghostRecord
The Trace database to delete (the parentDatabase and ghostDatabase should be set).

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Deletes the trace record associated with the parent database.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 11 or later
Header: APIdefs_Environment.h

 

See Also

ACAPI_Environment,
API_GhostRecord, APIEnv_CreateGhostRecordID, APIEnv_GetGhostRecordID, API Functions