API_​IFCPropertyTableValue

IFC property with a list of value pairs.

    typedef struct {
        GS::Array<API_IFCPropertyValue>     definingValues;
        GS::Array<API_IFCPropertyValue>     definedValues;
    } API_IFCPropertyTableValue;

 

Members

definingValues
List of defning values, must be unique
definedValues
List of defined values, does not have to be unique

 

Remarks

This structure contains a list of  value pairs of an IfcPropertTableValue.
The definingValues and definedValues shall have the same type inside, but the two types can differ.
The size of the two arrays shall be the same, at least one pair of values shall be set.

 

Requirements

Version: API 16 or later
Header: APIdefs_Elements.h

 

See Also

API_IFCProperty