APIDb_​GetRVMIssueDocumentRevisionsID

Retrieves all document revisions belong to the given issue.

    GSErrCode ACAPI_Database (
        APIDb_GetRVMIssueDocumentRevisionsID,
        const API_Guid*                           issueGuid,
        GS::Array<API_RVMDocumentRevision>*       api_revisions
    );

 

Parameters

issueGuid
GUID of the issue.
api_revisions
The array of the document revisions.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
issueGuid or api_revisions is nullptr.
APIERR_BADID
issueGuid does not identify a valid issue.
APIERR_GENERAL
Couldn’t get the document revisions.

For other common API errors see the API Errors document.

 

Remarks

You are able to get document revisions contained by the given issue.

 

Requirements

Version: API 18 or later
Header: APIdefs_Database.h

 

See Also

API_RVMDocumentRevision
ACAPI_Database
API Functions