APIIo_​IncProcessValueID

Increases the value of the progress bar.

    GSErrCode ACAPI_Interface (
        APIIo_IncProcessValueID,
        Int32*     incval
    );

 

Parameters

incval
[in] The value to add to the progress bar in the current process phase.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
incval is nullptr

For other common API errors see the API Errors document.

 

Remarks

This function is used to increase the progress bar value of the current phase in the process window. The increment should be passed in the incval parameter.

Use the APIIo_SetProcessValueID function to set the process value to a given value, instead of increasing the current one.

 

Example

See APIIo_InitProcessWindowID for example of using process windows.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

APIIo_InitProcessWindowID, APIIo_SetProcessValueID,
ACAPI_Interface, API Functions