API_​CWPlacement_​Type

Curtain wall junction placement type.

    typedef enum {
        APICW_Placement_AllGridPoints,
        APICW_Placement_Manual
    } API_CWPlacement_Type;

 

Members

APICW_Placement_AllGridPoints
Junctions will be placed at all grid points of Curtain wall.
APICW_Placement_Manual
Junctions will be placed mannually – one by one – in the grid points.

 

Remarks

The API_CWPlacement_Type type is used in the API_CWSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWBoundaryFramePosID, API_CWGridLineAssignType
API_CWSegmentType, API_CWSegmentCategoryID, API_CWSegmentGridOrigPosTypeID
API_CWSegmentType, API Types