API_​UnitType

Description of an unit.

    typedef struct {
        API_ListData_Head     head;
        char                  code[API_DBCodeLen];
        char                  name[API_DBCodeLen];
        Int32                 filler_1[8];
    } API_UnitType;

 

Members

head
Contains the header information, including type, setIndex and index.
code
code string
name
name of the unit

 

Remarks

This structure is used when you retrieve or search for an unit in the listing database. See the ACAPI_ListData_Get and ACAPI_ListData_Search functions.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_ListData.h

 

See Also

API_ListData_Head, API_ListData,
Listing Manager, API Types