API_​CWPanelRelation

Structure for retrieving connection data of a curtain wall panel, skylight, window or a door element.

    typedef struct {
        API_Guid     fromRoom;
        API_Guid     toRoom;
        double       filler[8];
    } API_CWPanelRelation, API_SkylightRelation, API_WindowRelation, API_DoorRelation;

 

Members

fromRoom
guid of the room connected to the requested element.
toRoom
guid of the room connected to the requested element.
filler
Reserved for further use.

 

Remarks

To learn more about the usage of this relation structure please refer to the ACAPI_Element_GetRelations function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_WallRelation, API_ConnectionGuidItem, API Types