API_​DimFormat

The representation of the linear, radial, level, elevation, door/window and parapet dimensioning on the Preferences / Dimensioning tab page.

    typedef struct {
        short                   unit;
        short                   roundInch;
        short                   lenDecimals;
        GS::Bool8               show0Whole;
        char                    show0Inch;
        API_ExtraAccuracyID     showSmall5;
        GS::Bool8               hide0Dec;
        char                    filler_0;
        short                   filler_1;
    } API_DimFormat;

 

Members

unit
the measurement system (m, cm, mm…)
roundInch
fractional inches (1, 2, 4, 8, 16, 32, 64)
lenDecimals
number of decimals (0, 1, 2, 3, 4)
show0Whole
show zeros to the left of the decimal point
show0Inch
show zeros to the left of the decimal inches
showSmall5
European methods for rounding decimal values
hide0Dec 6.1
hide zeros at the right of the decimal point

 

Remarks

This structure is a member of API_DimensionPrefs.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

API_DimensionPrefs
API_ExtraAccuracyID
API_AngDimFormat
API_AreaDimFormat
APIEnv_GetPreferencesID
API Types