APIDb_​BuildWindowValidatorID

Registers a new window validator for the given guid.

    GSErrCode ACAPI_Database (
        APIDb_BuildWindowValidatorID,
        const API_WindowValidatorInfo*       pValidatorInfo
    );

 

Parameters

pValidatorInfo
Contains the guid of a window which will be the owner of the new validator and an element and checksum list to track their changes.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
pValidatorInfo is nullptr
APIERR_MEMFULL
Not enough memory to complete the operation.
APIERR_GENERAL
There is already a validator registered for this guid.

For other common API errors see the API Errors document.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

ACAPI_Database
API Functions