The direction of a grid mesh.
typedef enum { API_GridMeshLeft = 0, API_GridMeshRight = 1, API_GridMeshLowerRight = 2, API_GridMeshLower = 3, API_GridMeshLowerLeft = 4, API_GridMeshUpperRight = 5, API_GridMeshUpper = 6, API_GridMeshUpperLeft = 7, API_GridMeshDirNum = 8 } API_GridMeshDirection;
Members
- API_GridMeshLeft
- API_GridMeshRight
- API_GridMeshLowerRight
- API_GridMeshLower
- API_GridMeshLowerLeft
- API_GridMeshUpperRight
- API_GridMeshUpper
- API_GridMeshUpperLeft
- API_GridMeshDirNum
Remarks
Defines the possible GridMesh directions
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Base.h
See Also
API_GridMeshHead, API_GridMeshVertex, API_GridMeshEdge, API_GridEdgeInfo
API_GridMeshLine, API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D, API_Surface3D
API Types