Retrieves all changes those given by unique change IDs.
GSErrCode ACAPI_Database ( APIDb_GetRVMChangesFromChangeIdsID, const GS::Array<GS::UniString>* changeIds, GS::Array<API_RVMChange>* api_changes );
Parameters
- changeIds
- The array of the change IDs.
- api_changes
- The array of the changes.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
changeIds
orapi_changes
isnullptr
.APIERR_GENERAL
- Couldn’t get the changes.
For other common API errors see the API Errors document.
Remarks
If only unique change IDs are owned, API_RVMChanges can be retrieved by this function.
Requirements
- Version: API 18 or later
- Header: APIdefs_Database.h
See Also
API_RVMChangeACAPI_Database
API Functions