ACAPI_​Element_​SolidLink_​GetFlags

Retrieves the flag of a Solid Operation Link.

    GSErrCode  ACAPI_Element_SolidLink_GetFlags (
        API_Guid     guid_Target,
        API_Guid     guid_Operator,
        GSFlags*     linkFlags
    );

 

Parameters

guid_Target Changed in API 11
[in] Identifies the target element.
guid_Operator Changed in API 11
[in] Identifies the operator element.
linkFlags
[out] Linking options (see Remarks).

 

Return Values

NoError
The function has completed with success.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADPARS
The linkFlags parameter is nullptr.
APIERR_LINKNOTEXIST
There is no Solid Link in the database between elements specified by guid_Target and guid_Operator.

For other common API errors see the API Errors document.

 

Remarks

This function retrieves the attribute flag of a Solid Operation Link identified by the Target and the Operator element.

The meaning of the flag bits:

APISolidFlag_OperatorAttrib

The new surfaces inherit the attributes of the operator

APISolidFlag_SkipPolygonHolesAPI 14

Use operator (roof or slab) without holes

 

Requirements

Version: API 4.2 or later
Header: ACAPinc.h

 

See Also

ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetTargets
ACAPI_Element_SolidLink_GetOperators
API Functions