API_​CWallLineComponent

Describes the lines separate the simple fills contained in composite structures.

    typedef struct {
        API_AttributeIndex ltypeInd;
        short              linePen;
        short              filler_1;
        Int32              filler_2[7];
    } API_CWallLineComponent;

 

Members

ltypeInd
The index of the line type attribute (1..n, where n is the number of not symbol line type attributes).
linePen
The index of the line pen [0..255]. 0 means the skin face line is hidden.

 

 

Requirements

Version: API 5.1 or later
Header: APIdefs_Attributes.h

 

See Also

API_CompWallType, API_AttributeDefExt, API_AttributeIndex,
API Types