Retrieves the target elements linked to an operator element.
GSErrCode ACAPI_Element_SolidLink_GetTargets ( API_Guid guid_Operator, GS::Array<API_Guid>* guid_Targets );
Parameters
- guid_Operator
- [in] The GUID of the operator element.
- guid_Targets
- [out] GUID list of the target elements linked to the operator element.
Return Values
NoError
- The function has completed with success.
APIERR_BADDATABASE
,APIERR_NOTMINE
- The function cannot operate on the current database.
APIERR_BADPARS
- The
guid_Targets
parameter isnullptr
.
For other common API errors see the API Errors document.
Remarks
This function retrieves a list of target elements associated with a given operator element with Solid Operation Link.
Requirements
- Version: API 4.2 or later
- Header: ACAPinc.h
See Also
ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetOperators
API Functions