Cancel changes in Hierarchical Elem (Curtain Wall, Stair, Railing, Beam, Column) editing mode.
GSErrCode ACAPI_Automate ( APIDo_CancelHierarchicalElemID );
Return Values
NoError
- The function has completed with success.
APIERR_REFUSEDCMD
- Archicad is not in Curtain Wall, Stair, Railing, Beam or Column editing mode.
For other common API errors see the API Errors document.
Remarks
You are able to cancel changes made in Curtain Walls, Stairs, Railings, Beams and Columns 3D editing mode via this function.
This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Automate.h