APIAny_​GetAutoTextFlagID

Returns the mode flag currently set for autotext replacing in retrieved texts.

    GSErrCode ACAPI_Goodies (
        APIAny_GetAutoTextFlagID,
        bool*     showAutoText
    );

 

Parameters

showAutoText
[out] The current value of the autotext flag.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed showAutoText parameter is nullptr.

For other common API errors see the API Errors document.

 

Remarks

This function is used to get the current mode which determines whether ACAPI_Element_GetMemo function retrieves the original content of the text and textual label element [false] (the database representation), or the interpreted one [true] (what you see on the user interface).

Use the APIAny_ChangeAutoTextFlagID function to change this flag.

 

Requirements

Version: API 10 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_ChangeAutoTextFlagID
ACAPI_Goodies
API Functions