ACAPI_​Body_​AddVertex

Adds a vertex to the body data object.

    GSErrCode  ACAPI_Body_AddVertex (
        void*                  bodyData,
        const API_Coord3D&     coord,
        UInt32&                index
    );

 

Parameters

bodyData
[in] The body data object to add the vertex to.
coord
[in] Position of the vertex to add.
index
[out] The index of the created vertex, can be used later to define edges.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter is nullptr; bodyData

For other common API errors see the API Errors document.

 

Remarks

This function is used to add a vertex to a body data object.

The returned index can be used to create edges with the ACAPI_Body_AddEdge function.

 

Example

See the example of the ACAPI_Body_AddPolygon function.

 

Requirements

Version: API 16 or later
Header: ACAPinc.h

 

See Also

ACAPI_Body_AddEdge, ACAPI_Body_AddPolyNormal, ACAPI_Body_AddPolygon,
ACAPI_Body_Create, ACAPI_Body_Finish, ACAPI_Body_Dispose,
Body Manager, API Functions