APIDb_​GetLayoutDatabasesID

Returns the list of unique IDs of all layout databases.

    GSErrCode ACAPI_Database (
        APIDb_GetLayoutDatabasesID,
        API_DatabaseUnId**            databaseUnIds,
        GS::Array<API_DatabaseUnId>*  databaseUnIdArray
    );

 

Parameters

databaseUnIds
[out] The list of layout database unique IDs. Note: this is not handle; it’s the address of a pointer. You’ll have to dispose it with BMpFree when you don’t need it any more.
databaseUnIdArray API version 22
[out] the array of layout databases, in a more recent form. Pass the address of an appropriate GS::Array<> to get the result. This parameter has precedence over the other databaseUnIds parameter.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
dbUnIDs is nullptr
APIERR_NOPLAN
the plan database does not exist

For other common API errors see the API Errors document.

 

Remarks

You can get the list of all layout databases with this function, then you can use APIDb_ChangeCurrentDatabaseID to switch to that database.

 

Example

See the Example of the APIDb_GetDatabaseInfoID function.

 

Requirements

Version: API 10 or later
Header: APIdefs_Database.h

 

See Also

API_DatabaseUnId
APIDb_GetDetailDatabasesID, APIDb_GetWorksheetDatabasesID, APIDb_GetMasterLayoutDatabasesID
APIDb_ChangeCurrentDatabase, APIDb_GetDatabaseInfoID
ACAPI_Database, API Functions