ACAPI_​AddOnObject_​ReleaseObjects

In teamwork mode this function releases the specified objects.

    GSErrCode  ACAPI_AddOnObject_ReleaseObjects (
        const GS::Array<API_Guid>&     objectGuids
    );

 

Parameters

objectGuids
[in] The list of the objects which must be released.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The passed parameter objectGuids is empty or contains APINULLGuid.
APIERR_BADID
If any of the objectGuids is not an AddOnObject GUID.

For other common API errors see the API Errors document.

 

Remarks

If any of the specified objects were modified, Send Changes operation will be performed in order to send the modified objects to server.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

AddOnObject Manager, API Functions