Changes the memo part of certain element types.
GSErrCode ACAPI_Element_ChangeMemo ( API_Guid& guid, UInt64 mask, const API_ElementMemo* memo );
Parameters
- guid
- [in] Guid of the element.
- mask
- [in] Specifies which part of a memo should be changed. Currently only
APIMemoMask_Polygon
is supported. - memo
- [in] The replacement memo. Don’t forget to dispose of it with ACAPI_DisposeElemMemoHdls when you are done.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- You called the function for element types other then slabs or roofs.
APIERR_BADPARS
- You called the function with a mask value other than
APIMemoMask_Polygon
, or you specified wrong parameters.
For other common API errors see the API Errors document.
Remarks
This function is used to change the memo part of certain element types. Currently you can change only the polygon data of polygonal elements. It is recommended to use the ACAPI_Element_Change function instead.
Requirements
- Version: API 2.1 or later
- Header: ACAPinc.h
See Also
API_Guid, API_ElementMemo
ACAPI_Element_GetMemo, ACAPI_DisposeElemMemoHdls
ACAPI_Element_Change, Element Manager, API Functions