ACAPI_​AnalyticalModel_​GetSegmentedSurfaceMember

Returns the Structural Analytical Model Surface Member segmented version associated with the selected Surface Element.

    GSErrCode  ACAPI_AnalyticalModel_GetSegmentedSurfaceMember (
        const API_Guid&                                amGuid,
        const API_Guid&                                elemGuid,
        GS::Array<API_AnalyticalSurfaceMember>&        surfaceMember,
        double                                         centralAngle,
        API_ExportIdMappingType&                       surfaceIdMapping
    );

 

Parameters

amGuid
[in] The unique identifier of the internal Structural Analytical Model.
elemGuid
[in] The unique identifier of the internal Surface Element.
surfaceMember
[out] The array of Structural Analytical Model Surface Member segments representing the Structural Analytical Model Surface Member data.
centralAngle
[in] The angle of segmentation for curved walls given in degrees.
surfaceIdMapping
[out] The mapping between Surface Elements edge/vertex ID and segments edge/vertex IDs

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Requirements

Version: API 24 or later
Header: .\ACAPI_Analytical_Adapter.hpp

 

See Also

API Functions