API_​CWallAccessoryType

Represents a curtain wall accessory element.

    typedef struct {
        API_Elem_Head               head;
        char                        filler_1[16];
        short                       pen;
        short                       filler_2;
        API_CWAccessoryCategory     category;
        API_Guid                    owner;
        API_Guid                    tag;
        GS::Bool8                   hasTag;
        GS::Bool8                   flipped;
        short                       filler_3[3];
        API_Guid                    refFrame;
    } API_CWallAccessoryType;

 

Members

head
General element header.
pen
For internal use.
filler_1
Reserved for further use.
category
Category of the junction. See API_CWJunctionCategory.
owner
Owner Curtain Wall.
tag
Object identifier.
hasTag
In normal case it is always true.
flipped
Curtain Wall Accessory is flipped?
filler_2
Reserved for further use.
refFrame
Accessory is always joins to a frame. This is the reference frame.

 

Remarks

The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWJunctionCategory
API_CurtainWallType, API_CWallFrameType, API_CWallJunctionType, API_CWallPanelType, API_CWallSegmentType
API_Polygon, API_Coord, API_PolyArc, API Types