API_​LineType

Represents a 2D line.

    typedef struct {
        API_Elem_Head           head;
        API_ExtendedPenType     linePen;
        API_AttributeIndex      ltypeInd;
        bool                    roomSeparator;
        bool                    filler_1[5];
        short                   determination;
        API_ArrowData           arrowData;
        double                  penWeight;
        Int32                   filler_2[8];
        API_Coord               begC;
        API_Coord               endC;
        Int32                   filler_3[8];
    } API_LineType;

 

Members

head
General element header.
linePen 20
(Overridden) pen attribute index.
ltypeInd
Line type attribute index.
roomSeparator
Is this line a zone boundary?
determination 6.1
Line category:

APILine_DetOrigin

Default line category. Lines in the Drafting line category are not affected by the Line Weight and Section Fill settings chosen in Display Options.

APILine_DetInnerLine

A skin separator line separates skins of composite structures. Lines in the Skin Separator category will be either hidden or shown depending on the Cut Fill type chosen in Display Options. Also, lines in the Skin Separator category can be optionally placed onto their own layer during DXF/DWG conversion functions.

APILine_DetContourLine

Lines in the Cut line category will be affected if you have chosen the ‘Bold Cut Line’ setting in the Line Weight menu of Display Options.

arrowData
Arrow data for the line ends.
penWeight
Pen weight for the line (can override the weight in linePen, otherwise set it to API_DefPenWeigth: use default weight of the pen).
begC
Coordinate of the first point.
endC
Coordinate of the second point.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Elem_Head, API_ArrowData, API_Coord, API_ExtendedPenType, API_Element,
Element Manager, API Types