APIAny_​APIGuidToIFCGuidID

It converts an API_Guid to an IfcGloballyUniqueId string.

    GSErrCode ACAPI_Goodies (
        APIAny_APIGuidToIFCGuidID,
        const API_Guid*     apiGuid,
        GS::UniString*      ifcGuid
    );

 

Parameters

apiGuid
[in] API_Guid need to be converted.
ifcGuid
[out] The resulting IfcGloballyUniqueId string.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
If any error occured during the conversion.

For other common API errors see the API Errors document.

 

Remarks

It converts an API_Guid to IfcGloballyUniqueId string.

For example “C2E63FBC-194A-4895-A7A8-62C9B0D5CC7B” is converted to “32vZ_y6Kf8bQUeOicmrSnx”.

 

Requirements

Version: API 18 or later
Header: APIdefs_Goodies.h

 

See Also

ACAPI_Goodies,
APIAny_IFCGuidToAPIGuidID