ACAPI_​AnalyticalModel_​GetComplementaryProjectMemberType

Returns the Analytical Member Type of a certain element from the Complementary Project.

    GSErrCode  ACAPI_AnalyticalModel_GetComplementaryProjectMemberType (
        const API_Guid&               elemGuid,
        API_AnalyticalMemberType&     analyticalMemberType
    );

 

Parameters

elemGuid
[in] The unique identifier of the Analytical Member element.
analyticalMemberType
[out] The type of the Analytical Member element from the Complementary Project.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

It is recommended to call this function before creating any Analytical Member and use its analyticalMemberType value if it is different than API_AnalyticalMember_UnknownType.

 

Requirements

Version: API 24 or later
Header: ACAPI_Analytical_Adapter.hpp

 

See Also

API API_AnalyticalCurveMember, API API_AnalyticalSurfaceMember,
API ACAPI_AnalyticalModel_CreateElementFromCurveMember, API ACAPI_AnalyticalModel_CreateElementFromSurfaceMember,
API Functions