ACAPI_​Element_​Trim_​Remove

Remove the trimming connection from the given elements.

    GSErrCode  ACAPI_Element_Trim_Remove (
        const API_Guid&     guid_Element1,
        const API_Guid&     guid_Element2
    );

 

Parameters

guid_Element1
[in] The first element GUID.
guid_Element2
[in] The second element GUID.

 

Return Values

NoError
The function has completed with success.
APIERR_NEEDSUNDOSCOPE
The function must be undoable, it wasn’t called from an undoable command scope.
APIERR_BADDATABASE, APIERR_NOTMINE
The function cannot operate on the current database.
APIERR_BADINDEX
One or more of the passed IDs are invalid.
APIERR_BADELEMENTTYPE
One of the elements is not construction element type or there is no given Roof or Shell.

For other common API errors see the API Errors document.

 

Remarks

This function removes trimming connection between the elements.

 

 

Requirements

Version: API 15 or later
Header: ACAPinc.h

 

See Also

API_TrimTypeID
ACAPI_Element_Trim_Elements
ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_GetTrimType
ACAPI_Element_Trim_GetTrimmedElements
ACAPI_Element_Trim_GetTrimmingElements
API Functions