API_​WallQuantity

Describes the different calculated values for walls.

    typedef struct {
        double     volume;
        double     volume_cond;
        double     volumeASkin;
        double     volumeBSkin;
        double     volumeASkin_cond;
        double     volumeBSkin_cond;
        double     surface1;
        double     surface2;
        double     surface3;
        double     surface1_cond;
        double     surface2_cond;
        double     length;
        double     windowsSurf;
        double     doorsSurf;
        double     emptyholesSurf;
        double     filler_0;
        Int32      columnsNumber;
        Int32      filler_1;
        double     windowsWidth;
        double     doorsWidth;
        double     minHeight;
        double     maxHeight;
        double     minHeightASkin;
        double     maxHeightASkin;
        double     minHeightBSkin;
        double     maxHeightBSkin;
        double     centerLength;
        double     area;
        double     perimeter;
        double     grossVolume;
        double     grossSurf1;
        double     grossSurf2;
        double     emptyHolesVolume;
        double     emptyHolesSurf1;
        double     emptyHolesSurf2;
        double     length12;
        double     length34;
        double     length12_cond;
        double     length34_cond;
        double     insuThickness;
        double     airThickness;
        double     skinAThickness;
        double     skinBThickness;
        double     refLineLength;
    } API_WallQuantity;

 

Members

volume
volume of the wall
volume_cond API 14
conditional volume of the wall
volumeASkin Changed in API 13
wall skin volume on the reference line side
volumeBSkin Changed in API 13
wall skin volume on the side opposite to the reference line
volumeASkin_cond Changed in API 13
conditional wall skin volume on the reference line side
volumeBSkin_cond Changed in API 13
conditional wall skin volume on the side opposite to the reference line
surface1
surface of the wall on the reference line side
surface2
surface of the wall on the side opposite to the reference line
surface3
surface of the edge of the wall
surface1_cond Changed in API 13
conditional surface of the wall on the reference line side
surface2_cond Changed in API 13
conditional surface of the wall on the side opposite to the reference line
length
length of the wall (average of the length on the reference line side and on the side opposite to the reference line)
windowsSurf
surface of windows in the wall
doorsSurf
surface of doors in the wall
emptyholesSurf
surface of empty openings in the wall
columnsNumber
number of columns in the wall
windowsWidth
combined width of windows in the wall
doorsWidth
combined width of doors in the wall
minHeight
Minimum height of the wall
maxHeight
Maximum height of the wall
minHeightASkin Changed in API 13
Minimum height of the wall skin on the reference line side
maxHeightASkin Changed in API 13
Maximum height of the wall skin on the reference line
minHeightBSkin Changed in API 13
Minimum height of the wall skin on the side opposite to the reference line
maxHeightBSkin Changed in API 13
Maximum height of the wall skin on the side opposite to the reference line
centerLength
Length of the wall at the center
area
Area of the wall
perimeter
Perimeter of the wall
grossVolume
Gross volume of the wall
grossSurf1
Gross surface of the wall on the reference line side
grossSurf2
Gross surface of the wall on the side opposite to the reference line
emptyHolesVolume
Analytic volume of openings in the wall
emptyHolesSurf1
Analytic surface of openings on the reference line side
emptyHolesSurf2
Analytic surface of openings on the side opposite to the reference line
length12 4.3
Length of the wall on the reference line side
length34 4.3
Length of the wall on the side opposite to the reference line
length12_cond Changed in API 13
Conditional length of the wall on the reference line side
length34_cond Changed in API 13
Conditional length of the wall on the side opposite to the reference line
insuThickness Changed in API 13
Wall insulation skin thickness
airThickness Changed in API 13
Wall air skin thickness
skinAThickness Changed in API 13
Wall skin thickness on the reference line side
skinBThickness Changed in API 13
Wall skin thickness on the side opposite to the reference line
refLineLength Changed in API 17
Length of the reference line

 

Remarks

See also the wall parameters for listing in Appendix A of the GDL Reference manual.

The columnsVolume member was never calculated, so we removed it in API 21.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API_QuantityPar, API_CalcRulesPrefs, API Types